logging.spec 2.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. {
  2. "module_spec": {
  3. "module_name": "Logging",
  4. "module_description": "Logging configuration",
  5. "config_data": [
  6. {
  7. "item_name": "loggers",
  8. "item_type": "list",
  9. "item_optional": false,
  10. "item_default": [],
  11. "list_item_spec":
  12. {
  13. "item_name": "logger",
  14. "item_type": "map",
  15. "item_optional": false,
  16. "item_default": {},
  17. "map_item_spec": [
  18. {
  19. "item_name": "name",
  20. "item_type": "string",
  21. "item_optional": false,
  22. "item_default": "kea",
  23. "item_description": "Logging name"
  24. },
  25. {
  26. "item_name": "output_options",
  27. "item_type": "list",
  28. "item_optional": true,
  29. "item_default": [],
  30. "list_item_spec":
  31. {
  32. "item_name": "output_option",
  33. "item_type": "map",
  34. "item_optional": false,
  35. "item_default": {},
  36. "item_description": "Options for a logging destination",
  37. "map_item_spec": [
  38. {
  39. "item_name": "output",
  40. "item_type": "string",
  41. "item_optional": false,
  42. "item_default": "stdout",
  43. "item_description": "Logging destination (stdout, stderr, syslog, syslog:name, file name)"
  44. },
  45. {
  46. "item_name": "maxver",
  47. "item_type": "integer",
  48. "item_optional": true,
  49. "item_default": 1,
  50. "item_description": "Maximum number of log files in rotation"
  51. },
  52. {
  53. "item_name": "maxsize",
  54. "item_type": "integer",
  55. "item_optional": true,
  56. "item_default": 204800,
  57. "item_description": "Maximum log file size"
  58. },
  59. {
  60. "item_name": "flush",
  61. "item_type": "boolean",
  62. "item_optional": true,
  63. "item_default": true,
  64. "item_description": "Immediate flush"
  65. }
  66. ]
  67. }
  68. },
  69. {
  70. "item_name": "severity",
  71. "item_type": "string",
  72. "item_optional": false,
  73. "item_default": "INFO",
  74. "item_description": "Logging severity"
  75. },
  76. {
  77. "item_name": "debuglevel",
  78. "item_type": "integer",
  79. "item_optional": true,
  80. "item_default": 0,
  81. "item_description": "Debug level (for DEBUG severity, 0..99 range)"
  82. }
  83. ]
  84. }
  85. }
  86. ]
  87. }
  88. }