bob.spec 988 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. {
  2. "module_spec": {
  3. "module_name": "Boss",
  4. "config_data": [
  5. {
  6. "item_name": "some_string",
  7. "item_type": "string",
  8. "item_optional": False,
  9. "item_default": "Hi, shane!"
  10. },
  11. {
  12. "item_name": "some_int",
  13. "item_type": "integer",
  14. "item_optional": False,
  15. "item_default": 1
  16. }
  17. ],
  18. "commands": [
  19. {
  20. "command_name": "print_message",
  21. "command_description": "Print the given message to stdout",
  22. "command_args": [ {
  23. "item_name": "message",
  24. "item_type": "string",
  25. "item_optional": False,
  26. "item_default": ""
  27. } ]
  28. },
  29. {
  30. "command_name": "print_settings",
  31. "command_description": "Print some_string and some_int to stdout",
  32. "command_args": []
  33. },
  34. {
  35. "command_name": "shutdown",
  36. "command_description": "Shut down BIND 10",
  37. "command_args": []
  38. }
  39. ]
  40. }
  41. }