bob.spec 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. {
  2. "module_spec": {
  3. "module_name": "Boss",
  4. "module_description": "Master process",
  5. "config_data": [
  6. {
  7. "item_name": "components",
  8. "item_type": "named_set",
  9. "item_optional": false,
  10. "item_default": {
  11. "b10-auth": { "special": "auth", "kind": "needed", "priority": 10 },
  12. "setuid": {
  13. "special": "setuid",
  14. "priority": 5,
  15. "kind": "dispensable"
  16. },
  17. "b10-xfrin": { "address": "Xfrin", "kind": "dispensable" },
  18. "b10-xfrout": { "address": "Xfrout", "kind": "dispensable" },
  19. "b10-zonemgr": { "address": "Zonemgr", "kind": "dispensable" },
  20. "b10-stats": { "address": "Stats", "kind": "dispensable" },
  21. "b10-stats-httpd": {
  22. "address": "StatsHttpd",
  23. "kind": "dispensable"
  24. },
  25. "b10-cmdctl": { "special": "cmdctl", "kind": "needed" }
  26. },
  27. "named_set_item_spec": {
  28. "item_name": "component",
  29. "item_type": "map",
  30. "item_optional": false,
  31. "item_default": { },
  32. "map_item_spec": [
  33. {
  34. "item_name": "special",
  35. "item_optional": true,
  36. "item_type": "string"
  37. },
  38. {
  39. "item_name": "process",
  40. "item_optional": true,
  41. "item_type": "string"
  42. },
  43. {
  44. "item_name": "kind",
  45. "item_optional": false,
  46. "item_type": "string",
  47. "item_default": "dispensable"
  48. },
  49. {
  50. "item_name": "address",
  51. "item_optional": true,
  52. "item_type": "string"
  53. },
  54. {
  55. "item_name": "params",
  56. "item_optional": true,
  57. "item_type": "list",
  58. "list_item_spec": {
  59. "item_name": "param",
  60. "item_optional": false,
  61. "item_type": "string",
  62. "item_default": ""
  63. }
  64. },
  65. {
  66. "item_name": "priority",
  67. "item_optional": true,
  68. "item_type": "integer"
  69. }
  70. ]
  71. }
  72. }
  73. ],
  74. "commands": [
  75. {
  76. "command_name": "shutdown",
  77. "command_description": "Shut down BIND 10",
  78. "command_args": []
  79. },
  80. {
  81. "command_name": "sendstats",
  82. "command_description": "Send data to a statistics module at once",
  83. "command_args": []
  84. },
  85. {
  86. "command_name": "ping",
  87. "command_description": "Ping the boss process",
  88. "command_args": []
  89. },
  90. {
  91. "command_name": "show_processes",
  92. "command_description": "List the running BIND 10 processes",
  93. "command_args": []
  94. }
  95. ],
  96. "statistics": [
  97. {
  98. "item_name": "boot_time",
  99. "item_type": "string",
  100. "item_optional": false,
  101. "item_default": "1970-01-01T00:00:00Z",
  102. "item_title": "Boot time",
  103. "item_description": "A date time when bind10 process starts initially",
  104. "item_format": "date-time"
  105. }
  106. ]
  107. }
  108. }