ddns.spec 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. {
  2. "module_spec": {
  3. "module_name": "DDNS",
  4. "config_data": [
  5. {
  6. "item_name": "zones",
  7. "item_type": "list",
  8. "item_optional": false,
  9. "item_default": [],
  10. "list_item_spec": {
  11. "item_name": "entry",
  12. "item_type": "map",
  13. "item_optional": true,
  14. "item_default": {
  15. "origin": "",
  16. "class": "IN",
  17. "update_acl": []
  18. },
  19. "map_item_spec": [
  20. {
  21. "item_name": "origin",
  22. "item_type": "string",
  23. "item_optional": false,
  24. "item_default": ""
  25. },
  26. {
  27. "item_name": "class",
  28. "item_type": "string",
  29. "item_optional": false,
  30. "item_default": "IN"
  31. },
  32. {
  33. "item_name": "update_acl",
  34. "item_type": "list",
  35. "item_optional": false,
  36. "item_default": [],
  37. "list_item_spec": {
  38. "item_name": "acl_element",
  39. "item_type": "any",
  40. "item_optional": true,
  41. "item_default": {"action": "REJECT"}
  42. }
  43. }
  44. ]
  45. }
  46. }
  47. ],
  48. "commands": [
  49. {
  50. "command_name": "shutdown",
  51. "command_description": "Shut down DDNS",
  52. "command_args": [
  53. {
  54. "item_name": "pid",
  55. "item_type": "integer",
  56. "item_optional": true
  57. }
  58. ]
  59. }
  60. ]
  61. }
  62. }