logging.spec 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. {
  2. "module_spec": {
  3. "module_name": "Logging",
  4. "module_description": "Logging configuration",
  5. "config_data": [
  6. {
  7. "item_name": "loggers",
  8. "item_type": "list",
  9. "item_optional": false,
  10. "item_default": [],
  11. "list_item_spec":
  12. {
  13. "item_name": "logger",
  14. "item_type": "map",
  15. "item_optional": false,
  16. "item_default": {},
  17. "map_item_spec": [
  18. {
  19. "item_name": "name",
  20. "item_type": "string",
  21. "item_optional": false,
  22. "item_default": "kea"
  23. },
  24. {
  25. "item_name": "output_options",
  26. "item_type": "list",
  27. "item_optional": true,
  28. "item_default": [],
  29. "list_item_spec":
  30. {
  31. "item_name": "output_option",
  32. "item_type": "map",
  33. "item_optional": false,
  34. "item_default": {},
  35. "map_item_spec": [
  36. {
  37. "item_name": "output",
  38. "item_type": "string",
  39. "item_optional": false,
  40. "item_default": "stdout"
  41. },
  42. {
  43. "item_name": "maxver",
  44. "item_type": "integer",
  45. "item_optional": true,
  46. "item_default": 1
  47. },
  48. {
  49. "item_name": "maxsize",
  50. "item_type": "integer",
  51. "item_optional": true,
  52. "item_default": 204800
  53. },
  54. {
  55. "item_name": "flush",
  56. "item_type": "boolean",
  57. "item_optional": true,
  58. "item_default": true
  59. }
  60. ]
  61. }
  62. },
  63. {
  64. "item_name": "severity",
  65. "item_type": "string",
  66. "item_optional": false,
  67. "item_default": "INFO"
  68. },
  69. {
  70. "item_name": "debuglevel",
  71. "item_type": "integer",
  72. "item_optional": true,
  73. "item_default": 0
  74. }
  75. ]
  76. }
  77. }
  78. ]
  79. }
  80. }