1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586 |
- {
- "module_spec": {
- "module_name": "Logging",
- "module_description": "Logging configuration",
- "config_data": [
- {
- "item_name": "loggers",
- "item_type": "list",
- "item_optional": false,
- "item_default": [],
- "list_item_spec":
- {
- "item_name": "logger",
- "item_type": "map",
- "item_optional": false,
- "item_default": {},
- "map_item_spec": [
- {
- "item_name": "name",
- "item_type": "string",
- "item_optional": false,
- "item_default": "kea"
- },
- {
- "item_name": "output_options",
- "item_type": "list",
- "item_optional": true,
- "item_default": [],
- "list_item_spec":
- {
- "item_name": "output_option",
- "item_type": "map",
- "item_optional": false,
- "item_default": {},
- "map_item_spec": [
- {
- "item_name": "output",
- "item_type": "string",
- "item_optional": false,
- "item_default": "stdout"
- },
- {
- "item_name": "maxver",
- "item_type": "integer",
- "item_optional": true,
- "item_default": 1
- },
- {
- "item_name": "maxsize",
- "item_type": "integer",
- "item_optional": true,
- "item_default": 204800
- },
- {
- "item_name": "flush",
- "item_type": "boolean",
- "item_optional": true,
- "item_default": true
- }
- ]
- }
- },
- {
- "item_name": "severity",
- "item_type": "string",
- "item_optional": false,
- "item_default": "INFO"
- },
- {
- "item_name": "debuglevel",
- "item_type": "integer",
- "item_optional": true,
- "item_default": 0
- }
- ]
- }
- }
- ]
- }
- }
|