spec2.spec 1.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. {
  2. "module_spec": {
  3. "module_name": "Spec2",
  4. "config_data": [
  5. { "item_name": "item1",
  6. "item_type": "integer",
  7. "item_optional": False,
  8. "item_default": 1
  9. },
  10. { "item_name": "item2",
  11. "item_type": "real",
  12. "item_optional": False,
  13. "item_default": 1.1
  14. },
  15. { "item_name": "item3",
  16. "item_type": "boolean",
  17. "item_optional": False,
  18. "item_default": True
  19. },
  20. { "item_name": "item4",
  21. "item_type": "string",
  22. "item_optional": False,
  23. "item_default": "test"
  24. },
  25. { "item_name": "item5",
  26. "item_type": "list",
  27. "item_optional": False,
  28. "item_default": [ "a", "b" ],
  29. "list_item_spec": {
  30. "item_name": "list_element",
  31. "item_type": "string",
  32. "item_optional": False,
  33. "item_default": ""
  34. }
  35. },
  36. { "item_name": "item6",
  37. "item_type": "map",
  38. "item_optional": False,
  39. "item_default": {},
  40. "map_item_spec": [
  41. { "item_name": "value1",
  42. "item_type": "string",
  43. "item_optional": True,
  44. "item_default": "default"
  45. },
  46. { "item_name": "value2",
  47. "item_type": "integer",
  48. "item_optional": True
  49. }
  50. ]
  51. }
  52. ],
  53. "commands": [
  54. {
  55. "command_name": "print_message",
  56. "command_description": "Print the given message to stdout",
  57. "command_args": [ {
  58. "item_name": "message",
  59. "item_type": "string",
  60. "item_optional": False,
  61. "item_default": ""
  62. } ]
  63. },
  64. {
  65. "command_name": "shutdown",
  66. "command_description": "Shut down BIND 10",
  67. "command_args": []
  68. }
  69. ]
  70. }
  71. }