123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497 |
- {
- "module_spec": {
- "module_name": "Dhcp6",
- "module_description": "DHCPv6 server daemon",
- "config_data": [
- {
- "item_name": "hooks-libraries",
- "item_type": "list",
- "item_optional": true,
- "item_default": [],
- "list_item_spec":
- {
- "item_name": "hooks-library",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- }
- },
- { "item_name": "interfaces",
- "item_type": "list",
- "item_optional": false,
- "item_default": [ "*" ],
- "list_item_spec":
- {
- "item_name": "interface_name",
- "item_type": "string",
- "item_optional": false,
- "item_default": "*"
- }
- } ,
- { "item_name": "renew-timer",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 1000
- },
- { "item_name": "rebind-timer",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 2000
- },
- { "item_name": "preferred-lifetime",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 3000
- },
- { "item_name": "valid-lifetime",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 4000
- },
- { "item_name": "option-def",
- "item_type": "list",
- "item_optional": false,
- "item_default": [],
- "list_item_spec":
- {
- "item_name": "single-option-def",
- "item_type": "map",
- "item_optional": false,
- "item_default": {},
- "map_item_spec": [
- {
- "item_name": "name",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- { "item_name": "code",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 0
- },
- { "item_name": "type",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- { "item_name": "array",
- "item_type": "boolean",
- "item_optional": false,
- "item_default": False
- },
- { "item_name": "record-types",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- { "item_name": "space",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- { "item_name": "encapsulate",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- } ]
- }
- },
- { "item_name": "option-data",
- "item_type": "list",
- "item_optional": false,
- "item_default": [],
- "list_item_spec":
- {
- "item_name": "single-option-data",
- "item_type": "map",
- "item_optional": false,
- "item_default": {},
- "map_item_spec": [
- {
- "item_name": "name",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- { "item_name": "code",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 0
- },
- { "item_name": "data",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- { "item_name": "csv-format",
- "item_type": "boolean",
- "item_optional": false,
- "item_default": False
- },
- { "item_name": "space",
- "item_type": "string",
- "item_optional": false,
- "item_default": "dhcp6"
- } ]
- }
- },
- { "item_name": "lease-database",
- "item_type": "map",
- "item_optional": false,
- "item_default": {"type": "memfile"},
- "map_item_spec": [
- {
- "item_name": "type",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- {
- "item_name": "name",
- "item_type": "string",
- "item_optional": true,
- "item_default": ""
- },
- {
- "item_name": "user",
- "item_type": "string",
- "item_optional": true,
- "item_default": ""
- },
- {
- "item_name": "host",
- "item_type": "string",
- "item_optional": true,
- "item_default": ""
- },
- {
- "item_name": "password",
- "item_type": "string",
- "item_optional": true,
- "item_default": ""
- },
- {
- "item_name": "persist",
- "item_type": "boolean",
- "item_optional": true,
- "item_default": true
- }
- ]
- },
- { "item_name": "subnet6",
- "item_type": "list",
- "item_optional": false,
- "item_default": [],
- "list_item_spec":
- {
- "item_name": "single-subnet6",
- "item_type": "map",
- "item_optional": false,
- "item_default": {},
- "map_item_spec": [
- { "item_name": "subnet",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- { "item_name": "id",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 0
- },
- { "item_name": "interface",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- { "item_name": "interface-id",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- { "item_name": "renew-timer",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 1000
- },
- { "item_name": "rebind-timer",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 2000
- },
- { "item_name": "preferred-lifetime",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 3000
- },
- { "item_name": "valid-lifetime",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 7200
- },
- { "item_name": "pool",
- "item_type": "list",
- "item_optional": false,
- "item_default": [],
- "list_item_spec":
- {
- "item_name": "type",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- }
- },
- { "item_name": "client-class",
- "item_type": "string",
- "item_optional": false,
- "item_default": "",
- "item_description" : "Restricts access to this subnet to specified client class (if defined)"
- },
- { "item_name": "relay",
- "item_type": "map",
- "item_optional": false,
- "item_default": {},
- "item_description" : "Structure holding relay information.",
- "map_item_spec": [
- {
- "item_name": "ip-address",
- "item_type": "string",
- "item_optional": false,
- "item_default": "::",
- "item_description" : "IPv6 address of the relay (defaults to :: if not specified)."
- }
- ]
- },
- {
- "item_name": "pd-pools",
- "item_type": "list",
- "item_optional": true,
- "item_default": [],
- "list_item_spec":
- {
- "item_name": "pd-pool",
- "item_type": "map",
- "item_optional": false,
- "item_default": {},
- "map_item_spec": [
- {
- "item_name": "prefix",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- {
- "item_name": "prefix-len",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 128
- },
- {
- "item_name": "delegated-len",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 128
- }]
- }
- },
- { "item_name": "option-data",
- "item_type": "list",
- "item_optional": false,
- "item_default": [],
- "list_item_spec":
- {
- "item_name": "single-option-data",
- "item_type": "map",
- "item_optional": false,
- "item_default": {},
- "map_item_spec": [
- {
- "item_name": "name",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- {
- "item_name": "code",
- "item_type": "integer",
- "item_optional": false,
- "item_default": 0
- },
- {
- "item_name": "data",
- "item_type": "string",
- "item_optional": false,
- "item_default": ""
- },
- { "item_name": "csv-format",
- "item_type": "boolean",
- "item_optional": false,
- "item_default": False
- },
- { "item_name": "space",
- "item_type": "string",
- "item_optional": false,
- "item_default": "dhcp6"
- } ]
- }
- } ]
- }
- },
- { "item_name": "dhcp-ddns",
- "item_type": "map",
- "item_optional": false,
- "item_default": {"enable-updates": false},
- "item_description" : "Contains parameters pertaining DHCP-driven DDNS updates",
- "map_item_spec": [
- {
- "item_name": "enable-updates",
- "item_type": "boolean",
- "item_optional": false,
- "item_default": false,
- "item_description" : "Enables DDNS update processing"
- },
- {
- "item_name": "server-ip",
- "item_type": "string",
- "item_optional": true,
- "item_default": "127.0.0.1",
- "item_description" : "IP address of b10-dhcp-ddns (IPv4 or IPv6)"
- },
- {
- "item_name": "server-port",
- "item_type": "integer",
- "item_optional": true,
- "item_default": 53001,
- "item_description" : "port number of b10-dhcp-ddns"
- },
- {
- "item_name": "sender-ip",
- "item_type": "string",
- "item_optional": true,
- "item_default": "",
- "item_description" : "IP address from which to send to b10-dhcp-ddns (IPv4 or IPv6)"
- },
- {
- "item_name": "sender-port",
- "item_type": "integer",
- "item_optional": true,
- "item_default": 0,
- "item_description" : "port number from which to send to b10-dhcp-ddns"
- },
- {
- "item_name": "max-queue-size",
- "item_type": "integer",
- "item_optional": true,
- "item_default": 1024,
- "item_description" : "maximum number of requests allowed in the send queue"
- },
- {
- "item_name": "ncr-protocol",
- "item_type": "string",
- "item_optional": true,
- "item_default": "UDP",
- "item_description" : "Socket protocol to use with b10-dhcp-ddns"
- },
- {
- "item_name": "ncr-format",
- "item_type": "string",
- "item_optional": true,
- "item_default": "JSON",
- "item_description" : "Format of the update request packet"
- },
- {
- "item_name": "always-include-fqdn",
- "item_type": "boolean",
- "item_optional": true,
- "item_default": false,
- "item_description": "Enable always including the FQDN option in its response"
- },
- {
- "item_name": "override-no-update",
- "item_type": "boolean",
- "item_optional": true,
- "item_default": false,
- "item_description": "Do update, even if client requested no updates with N flag"
- },
- {
- "item_name": "override-client-update",
- "item_type": "boolean",
- "item_optional": true,
- "item_default": false,
- "item_description": "Server performs an update even if client requested delegation"
- },
- {
- "item_name": "replace-client-name",
- "item_type": "boolean",
- "item_optional": true,
- "item_default": false,
- "item_description": "Should server replace the domain-name supplied by the client"
- },
- {
- "item_name": "generated-prefix",
- "item_type": "string",
- "item_optional": true,
- "item_default": "myhost",
- "item_description": "Prefix to use when generating the client's name"
- },
- {
- "item_name": "qualifying-suffix",
- "item_type": "string",
- "item_optional": true,
- "item_default": "example.com",
- "item_description": "Fully qualified domain-name suffix if partial name provided by client"
- },
- ]
- },
- ],
- "commands": [
- {
- "command_name": "shutdown",
- "command_description": "Shuts down DHCPv6 server.",
- "command_args": [
- {
- "item_name": "pid",
- "item_type": "integer",
- "item_optional": true
- }
- ]
- },
- {
- "command_name": "libreload",
- "command_description": "Reloads the current hooks libraries.",
- "command_args": []
- }
- ]
- }
- }
|